Solución con Unity 3D - Ubuntu 12.04 -Nvidia

  • Categoría: Linux
  • Publicado hace más de 4 años
Hola, esto es para los que no han podido disfrutar Unity 3D en Nvidia GeForce de las series 6, 7 y algunos casos de la serie 8. Si la pantalla se les queda en negro con sólo el puntero o algo similar lo que sigue podría funcionar.
 
Según la fuente original de esta información (http://ubuntualways.wordpress.com/2012/05/01/solucion-al-problema-de-nvidia-con-unity-3d-en-ubuntu-12-04/#comment-242) ha funcionado en las siguientes placas:
 
Nvidia GeForce 7000M
 
Nvidia GeForce Go 7400
 
Nvidia GeForce 6150 LE nForce 430
 
Nvidia GeForce 6150 SE nForce 430
 
Nvidia 610 M 1 GB

 
Nvidia GeForce 7150M nForce 630M
 
Yo tengo Nvidia GeForce 6150 SE nForce 430 y ahora ando con Unity 3D. La solución de dónde tome esto menciona el controlador 295.33 como la versión que debe aplicarse pero a mí no me apareció, así que utilicé "302.17 nvidia-current".

1- Agregamos PPA:
 
Introducimos lo siguiente en la Terminal:
 
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
 
sudo apt-get update

 
2- Nos dirigimos al Gestor de Paquetes Synaptic, lo descargan si no lo tienen.
 
En el buscador ponemos "Nvidia" y en los resultados buscamos "nvidia_current", lo seleccionamos y vamos al menú donde dice: Paquete -> Forzar Versión:




Si no ven la imagen: http://ubuntualways.files.wordpress.com/2012/05/captura-de-pantalla-de-2012-04-17-173145.jpg?w=300&h=153
 
Dice en la fuente original que busquemos "295.33", yo no la encontré entonces utilicé "302.17"; la seleccionamos y le damos a Force Version, aplicamos cambios y no cerramos Synaptic aún. Despúes de aplicar los cambios seleccionamos el paquete de nuevo y en el menú de opciones: Paquete -> Bloquear Versión. Comprobamos que todo esté como en la imagen:




Si no se ve la imagen : http://ubuntualways.files.wordpress.com/2012/05/captura-de-pantalla-de-2012-05-01-141145.png?w=300&h=194
 
Lo siguiente es lo que debe estar instalado, debe quedar así; si aparece otro paquete instalado y que no está en la imagen entonces se desinstala. Es decir, si existe un paquete que en la imagen está desinstalado entonces ustedes lo desinstalan.
 
nvidia-settings
nvidia-settings-updates
nvidia-com....

nvidia-current
 
3- Editar archivo Environment
 
Introducimos en Terminal:
 
sudo gedit /etc/environment
 
Esto lo agregamos al final:

 
UNITY_FORCE_START=1
 
Guardamos y cerramos.
 
Abrimos el Centro de Software de Ubuntu y buscamos "Compiz" e instalamos lo de la imagen:
 




Si no se ve la imagen: http://ubuntualways.files.wordpress.com/2012/05/captura-de-pantalla-de-2012-05-01-145044.png?w=300&h=195
 
Reiniciamos; espero que disfruten del controlador instalado.





Si no ven la imagen: http://ubuntualways.files.wordpress.com/2012/05/captura-de-pantalla-de-2012-05-01-150113.png?w=300&h=187
 
A mí me ha funcionado, háganlo bajo su propio riesgo. Saludos!


El usuario @captura en http://www.tadinga/ me había comentado otra solución:

 
 @captura  
 
 Pero en mi compu, quiero hacer eso, pero cuando voy al menú paquetes, forzar versión, esa opción no la tengo!

@A4driano

- Dale a "Recargar" e intentas de nuevo.

@A4driano

Acá me pasaste este link: http://ubuntuforums.org/showthread.php?p=11944418

Dices que lo solucionaste con eso sólo que cambiando el comando para el "302.17". Espero que le sirva a alguno.
 
 
@captura


Si, ahora me anda bien el Ubuntu en mi compu de escritorio siguiendo esos pasos. Habían más cosas para hacer que cambiar un solo 302.17, pero si uno ve bien la consola, las opciones están a la vista.

Lo que también logre hacer funcionar, es que mi notebook conectase al wifi de mi casa, que lo detectaba pero no quería conectar, me pedía la contraseña todo el tiempo siendo que se la ponía bien.

Si siente que el Unity les anda un poco lento, entonces pueden mejorarlo con el Administrador de Opciones de Compiz:
 
sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra
 
0- En "Filtro" buscan "Unity" y abren Ubuntu Unity Plugin.
1- Se van a la pestaña "Experimental" y buscan "Dash Blur".
2- Seleccionan "No Blur".
 
Eso es todo.
Solución con Unity 3D - Ubuntu 12.04 -Nvidia
5 Puntos Score: 5/10
Visitas: 755 Favoritos: 1
Ver los usuarios que votaron...
1 Comentarios Solución con Unity 3D - Ubuntu 12.04 -Nvidia
buen post... yo tengo una nvidia gt 540m... lo voy a probara ver si va...
 
Para dejar un comentario Registrate! o.. eres ya usuario? Accede!