Cambiar autocierre de YAST

  • Categoría: Linux
  • Publicado hace más de 2 años

YAST.openSUSE


Desde la versión 11.0 , YAST, el instalador de programas de openSuse tiene un comportamiento antipático: se cierra automáticamente después de instalar un programa (en las versiones anteriores permanecía abierto hasta que tu le dijeras ?cierrate?).

Esto es algo bastante molesto sobretodo cuando, por ejemplo, te pones a instalar paquetes de desarrollo para compilar algún programa.

Para evitar este comportamiento de YAST en el que se cierra después de cada instalación/desinstalación de software edita como root /etc/sysconfig/yast2 y en la última línea verás algo como:
 
 ## Type: list(close,restart,summary)
 ## Default: "close"
 # Set the default behavior of the package manager when package installation has finished.
 # Possible actions are:
 #   close - just finish the package manager
 #   restart - go back to the package manager, install/remove more packages
 #   summary - display an installation summary dialog, there user can decide whether to finish or restart
 # The summary dialog is always displayed when an installation error has occured.
 PKGMGR_ACTION_AT_EXIT="close"

Cambiar close en la última línea por restart ó summary.


< fuente >




Cambiar autocierre de YAST
10 Puntos Score: 5/10
Visitas: 292 Favoritos: 0
Ver los usuarios que votaron...
6 Comentarios Cambiar autocierre de YAST
Que tal amigo, excelentes tus aportes linuxeros  , tengo instalada la version 13.1 y lo que me aparece difiere un poco de lo que pusiste. Lo que aparece editando mi archivo yast2 es esto:

## Type: list(yes,no)
## Default: "no"
#
# By default the recommended packages for already installed packages are not taken into
# account, i.e. they are not automatically selected for installation.
# Set this option to "yes" if you want to reevaluate which packages are recommended, e.g. to
# get the language dependent packages for an additional language or hardware related packages
# if the hardware has changed.
PKGMGR_REEVALUATE_RECOMMENDED="no"

## Type: list(yes,no)
## Default: "no"
# Enable use of snapper for YaST.
USE_SNAPPER="no"

Cual deberia modificar?. Un saludo cordial amigo y que sigan los buenos aportes.
Mis primeras distros. Open suse y Mandrivia que recuerdos. Pero ahora volvi de nuevo con una nueva distro que se me hace muy buena Linux Mint 17.
Para dejar un comentario Registrate! o.. eres ya usuario? Accede!