Ejercicios Hechos En Pseint

Ejercicios En Pseint








¿Qué es PSeInt?
PSeInt es una herramienta para asistir a un estudiante en sus primeros pasos en programación. Mediante un simple e intuitivo pseudolenguaje en español (complementado con un editor de diagramas de flujo), le permite centrar su atención en los conceptos fundamentales de la algoritmia computacional, minimizando las dificultades propias de un lenguaje y proporcionando un entorno de trabajo con numerosas ayudas y recursos didácticos.

Ejercicio 1:

En  un  supermercado  se  hace  una  promoción  mediante  la  cual  el  cliente  obtiene  un 
descuento  dependiendo  de  un  número  que  escoge  al  azar.  Si  el  número  escogido  es 
menor a 74 el descuento es del 15% sobre el total de la compra y si es mayor o igual a 74 
es de 20%. Obtener cuánto dinero se le descuenta y el pago final.

Codigo Pseint:
Proceso Ejercicio1
    Definir ctotal, pfinal, numclient, desc Como Real;
    Escribir "Ingrese el monto total de la compra";
    Leer ctotal;
    Escribir "Ingrese el numero escogido por el cliente";
    Leer numclient;
    Si numclient<74 Entonces
        desc<-ctotal*0.15;
    Sino
        desc<-ctotal*0.20;
    FinSi
    pfinal<-ctotal-desc;
    Escribir "El descuento es: $",desc;
    Escribir "El total a pagar es: $",pfinal;
FinProceso


Ejercicio 2: 

Elaborar un sistema de facturación que pida el nombre del vendedor, nombre del cliente, fecha  de  factura,  número  de  factura  y  suma  de  ventas  realizadas.  A  la  suma  de  ventas realizadas, se les hará un descuento según la siguiente tabla:

VENTAS                  DESCUENTO
  0    <   V < 100          0%
100  <= V <=500         15%
500  <   V <=1000       20%
              V>1000        30%

Codigo Pseint: 
Proceso Ejercicio2
    Definir nv, nc, ff, nf Como Caracter;
    Definir sv, desc, vn Como Real;
    Escribir "Ingrese el nombre del vendedor";
    Leer nv;
    Escribir "Ingrese el nombre del cliente";
    Leer nc;
    Escribir "Ingrese la fecha de la factura";
    Leer ff;
    Escribir "Ingrese el numero de la factura";
    Leer nf;
    Escribir "Ingrese la suma de las ventas realizadas";
    Leer sv;
    Si sv>0 y sv<100 entonces
        desc<-0;
    Sino
        Si sv>=100 y sv<=500 Entonces
            desc<-sv*0.15;
        Sino
            Si sv>500 y sv <=1000 Entonces
                desc<-sv*0.20;
            Sino
                desc<-sv*0.30;
            FinSi
        FinSi
    FinSi
    vn<-sv-desc;
    Escribir "";
    Escribir "Factura No: ", nf;
    Escribir "Fecha: ",ff;
    Escribir "Cliente: ",nc;
    Escribir "";
    Escribir "El total a pagar es: ",vn;
   
FinProceso


Ejercicio 3:

Una frutería ofrece las manzanas con descuento según la siguiente tabla:

KILOS COMPRADOS       % DESCUENTO
0  ->  2                              0% 
2.01  ?> 5                         10%
5.01 ?> 10                        15%
10.01 ?> en adelante          20%

Determinar cuánto pagará una persona que compre manzanas en esa frutería.

Codigo Pseint:
Proceso ejercicio3
    Definir kilos, precio, desc, totpag, netopag Como Real;
    Escribir "Ingrese el numero de Kilos comprados";
    Leer kilos;
    Escribir "Ingrese el precio por Kilo" ;
    Leer precio;
    totpag<-kilos*precio;
    Si kilos>0 y kilos<=2 Entonces
        desc<-0;
    Sino
        Si kilos>2.0 y kilos<=5 Entonces
            desc<-totpag*0.1;
        Sino
            Si kilos>5.0 y kilos <=10.0 Entonces
                desc<-totpag*0.15;
            Sino
                desc<-totpag*0.20;
            FinSi
        FinSi
    FinSi
    netopag<-totpag-desc;
    Escribir "Kilos comprados: ", kilos;
    Escribir "Precio por Kilo: $", precio;
    Escribir "Total a pagar: ", totpag;
    Escribir "Descuento: -$", desc;
    Escribir "Neto a pagar: $", netopag;
   
FinProceso


Ejercicio 4:

Una librería vende libros con las condiciones siguientes:
Si el cliente es tipo 1 se le descuenta el 30%, si es tipo 2 se le descuenta 20% y si es tipo 3 se le descuenta el 10%. Si la cantidad de libros solicitada es mayor que 50, se hace un descuento adicional de 5%; en caso de ser mayor que 100 el descuento adicional es de 10%.
Cuando el cliente realiza una compra se generan los datos siguientes:
Nombre del cliente, Tipo de cliente (1, 2,3),  cantidad en libros  y costo  por  libro. Leer  estos datos e imprimir: Nombre del cliente, total a pagar, descuento y neto a pagar.

Codigo Pseint: 
Proceso Ejercicio4
    Definir nc Como Caracter;
    Definir cdl, tc Como Entero;
    Definir cpl, totpag, desc, netopag, masdesc Como Real;
    Escribir "Ingrese el nombre del cliente";
    Leer nc;
    Escribir "Ingrese el tipo de cliente, Solo puede ser (1,2 ó 3)";
    Leer tc;
    Mientras tc<1 o tc>3 Hacer
        Escribir "Error el tipo de cliente solo puede ser 1, 2, ó 3";
        Escribir "Ingrese de nuevo el tipo de cliente";
        Leer tc;
    FinMientras
    Escribir "Ingrese la cantidad de libros de esta venta";
    Leer cdl;
    Escribir "Digite el costo por libro ";
    Leer cpl;
    totpag<-cdl*cpl;
   
    Si cdl<=50 Entonces
        masdesc<-0;
    Sino
        Si cdl>50 y cdl<=100 Entonces
        masdesc<-0.05;
        Sino
        masdesc<-0.10;
        FinSi
    FinSi
   
    Si tc=1 Entonces
        desc<-totpag*(0.30+masdesc);
    Sino
        Si tc=2 Entonces
            desc<-totpag*(0.20+masdesc);
        Sino

            desc<-totpag*(0.10+masdesc);
        FinSi
    FinSi
    netopag<-totpag-desc;
    Escribir "Nombre del cliente: ", nc;
    Escribir "Total a pagar $: ", totpag;
    Escribir "Descuento: $", desc;
    Escribir "Neto a pagar: $", netopag;
FinProceso

Ejercicio 5


La siguiente se llama conjetura de ULAM, en honor del matemático S. Ulam: Comience con un entero positivo. Si este entero es par, divídalo entre 2 y si es impar multiplíquelo por 3 y agréguele 1. El proceso se repite sucesivamente y al final se obtendrá el número 1, independiente del número inicial. Por ejemplo, cuando el entero inicial es 26, la secuencia será: 26  13  40  20  10  5 16  8  4  2  1.

Codigo Pseint:

Proceso ULAM
    Definir num Como Entero;
    Escribir "Digite un numero";
    Leer num;
    Escribir num;
   
    Repetir
        Si num mod 2 = 0 Entonces
            num<-num/2;
        Sino
            num<-num*3;
            num<-num+1;
        FinSi
       
        Escribir num;
    Hasta Que num=1
FinProceso







Descargar Pseint

Enlaces De Descarga
Ejercicios Hechos En Pseint
13 Puntos Score: 4.3/10
Visitas: 5649 Favoritos: 7
Ver los usuarios que votaron...
4 Comentarios Ejercicios Hechos En Pseint
men esto me hacia falta el a?
que buena onda!!! si tenes mas, subi por favor! saludos!
Para dejar un comentario Registrate! o.. eres ya usuario? Accede!